Jump to content
John Lewis give 2 year guarantee on white goods appliances

 

Beko WDR 7543121W not drying and keeps turning self off


Recommended Posts

So I had a Beko WDR 7543121B. It worked great, after 9 months the dryer started failing to heat. It got repaired and sorted. 3 months later it began to cut out during wash cycles. It got repaired. 3 months later, cutting out on wash leaving clothes soaked. Onto dry cycle, will run for 2 hours and not take any dampness out because it gets super hot and leaves every thing wet with steam. 

 

Over 7 weeks it had 8 repairs, replacing circuit boards, heating elements, filters and connectors. Still same problem. So my extended warranty replaced it. 

 

Brand new one today Beko WDR 7543121W  same model, but white instead of black. First wash, with a 90 minute dry cycle. Shut down during wash. Tried a dry cycle, no heat, everything still wet. Unplugged and tried again, and now we have superhot steamy clothes again. 

 

Any idea what going on? Cause Beko and the local engineers have no clue what so ever as to what's causing it and with a disabled wife and young child, having no washer dryer is a huge issue.

 

Can't have separate machines, because it's a small terrace with galley kitchen and there's only room for one unit. 

Link to post
Share on other sites

Hello. It is highly unusual of course for two totally separate washing machines to have the same fault. So the first thoughts have to be with what they have in common, and that is the plumbing and the socket it is plugged into. With washing machines cutting out at random you have to make sure that the wall socket is not to blame. I had exactly the same thing happen with my microwave. It would be working okay and suddenly just petered out then cut out. It turned out to be a loose wire inside the wall socket. The wire had been overheating and was quite burnt.

So first of all try to plug the washing machine into an entirely separate wall socket. If this is not physically possible you may need to use an extension lead temporarily. Make sure it is rated for 13 amps though! The cable should be the same thickness or thicker than the cable and the washing machine.

After that, a very common cause of a washer dryer leaving the laundry hot and steamy is if the cold water supply is not available during the drying cycle. There are other causes as well but as I said it seems highly unlikely that a brand-new washing machine would have the same fault. Check my article here for more information Laundry comes out of washer dryer hot & steamy

Also make sure there isn't a problem with the cold water supply such as a kinked fill hose. That would definitely cause problems on wash cycle too. When you put the washing machine and I wash cycle make sure water is coming into the so dispense a drawer at a reasonable flowrate.

Need a repair or spare parts? 

Book a Repair | Buy Spares (Cheapest prices guaranteed)

Warning:  Read this before attempting any diy repairsNo representations or warranties are made (express or implied) as to the reliability, accuracy or completeness of advice. I can't be held liable for any loss arising directly or indirectly from the use of, or any action taken in reliance on, any information on this website, which is given free of charge and in good faith.

Link to post
Share on other sites
  • 6 months later...

Hi - I have an issue with a 3 year old Beko WDR7543121 washer/dryer. It washes great but when it comes to drying, whether on a normal wash/dry cycle or timed cycle (use this most) it won't dry. The pump takes in water and it spins a little, drum rotates, all the correct light symbols come on but then after 5 minutes the timer clicks off and goes back to original timed heat start time and then stops. Watching the process with the lid off, the little fan doesn't work but there is correct power going to all contacts and the reset button hasn't clicked out. Can't reset via the control panel, doesn't work for this machine apparently.

I've put on a new solenoid but same thing happens. Any further ideas please?  my service engineer is totally flumoxed!

Link to post
Share on other sites
  • 1 month later...
On 03/02/2020 at 14:10, Dianne said:

but then after 5 minutes the timer clicks off and goes back to original timed heat start time and then stops

Does the heater work? If everything else appears to be working okay the implication is that the heating element is not working and the program is detecting there is no heat, or maybe the heat it is working and if the fan isn't running properly always blocked it is quickly overheating and cutting out? So to troubleshoot you need to establish if the heating element is working or not.

Need a repair or spare parts? 

Book a Repair | Buy Spares (Cheapest prices guaranteed)

Warning:  Read this before attempting any diy repairsNo representations or warranties are made (express or implied) as to the reliability, accuracy or completeness of advice. I can't be held liable for any loss arising directly or indirectly from the use of, or any action taken in reliance on, any information on this website, which is given free of charge and in good faith.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Book your Repair

Book washing machine & appliance repairs

Order your Spares

Ransom Spares is a family company with over 1 million white goods appliance spare parts for sale. Next day delivery available, friendly company with over 5000 reviews on Trust Pilot

Price match promise: "If you find the exact same part or accessory elsewhere for cheaper, we’ll not only match it, we’ll beat it!" -

Buy your appliance spare part



×
×
  • Create New...