Jump to content
Dav31

Miele W504 plus water protection system activated

Recommended Posts

Hi, I'm first time poster here and would appreciate if someone can help with this issue. Basically, I have this oldish miele that has never  failed us and now it is coming up with check water inlet and check water drain pipe warning lights, both together towards end of cycle. It came back after few washes  having cleared it once by tilting machine slightly to deactivate sensor, which I found out about from online help.

Now the question I have is if this happens again, could it be fault with the water protection activation sensor that brings up these warning lights to protect excessive water leakage? I mean, both times this has happened, I haven't seen any visible water spillage other than maybe whatever slight spillage there may be in the built in tray under the machine and rocking the machine to deactivate hasn't  resulted in water spillage either. Are you able to shed some light as to why this sensor has cut out twice and may possibly trip again

Share this post


Link to post
Share on other sites

Book washing machine & appliance repairs Buy appliance spare parts

Note: The links above are needed to help keep this site running, please consider using them.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×