Jump to content

Recommended Posts

Worked yesterday now today there is no power, it's as if no power is going in but I know that the plug fuse and switch fuse are both ok.

opened up and had a look, the door lock mechanism seems fine no signs of damage the same goes for other electrical parts along the top of the machine, I have not worked out how to take out the front panel pcb but it seems in good order (no burning smells.)

Does anyone have any idea what could be causing this?

 

All help appreciated .

 

Best

 

Hugh

 

ps I have pictures if needed. 

Link to post
Share on other sites

Hello Hugh. The door interlock could be faulty with no visible signs. But unfortunately this fault can be caused by many different things. The possible issues extend to the main PCB. With this fault it is normally advisable to get an engineering if you cannot see any of the obvious problems such as fuse, plug, and wall socket and you cannot see any obvious problems inside the machine.

My article here covers all the usual suspects - washing machine dead and no power - but you really need continuity test meter and to be able to trace the path of the electricity through the machine in order to track down the fault.

Need a repair or spare parts? 

Book a Repair | Buy Spares (Cheapest prices guaranteed)

Warning:  Read this before attempting any diy repairsNo representations or warranties are made (express or implied) as to the reliability, accuracy or completeness of advice. I can't be held liable for any loss arising directly or indirectly from the use of, or any action taken in reliance on, any information on this website, which is given free of charge and in good faith.

Link to post
Share on other sites

Thanks for the reply Andy, and let's say that it is the door lock. Surely, in this case, there would be some lights showing up on the front panel or slight humming sound if listening to washing machine  unless of course the door locking mechanism overrides the overall power LED's included?

 

Thanks for your reply.

 

Hugh

 

ps I tried uploading pictures I resized them small 6 pictures in total average size 60kb's (360kb's in total size) but your uploader wouldn't upload any? I thought it may be a glitch and to let you know. (thanks again Andy.)

Link to post
Share on other sites

Yes sorry if it was the door lock the control panel should still light up and operate. Did the uploader give any errors? I just attached a pic using the "choose files..." link and it worked ok for me.

Need a repair or spare parts? 

Book a Repair | Buy Spares (Cheapest prices guaranteed)

Warning:  Read this before attempting any diy repairsNo representations or warranties are made (express or implied) as to the reliability, accuracy or completeness of advice. I can't be held liable for any loss arising directly or indirectly from the use of, or any action taken in reliance on, any information on this website, which is given free of charge and in good faith.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Book your Repair

Book washing machine & appliance repairs

Order your Spares

Ransom Spares is a family company with over 1 million white goods appliance spare parts for sale. Next day delivery available, friendly company with over 5000 reviews on Trust Pilot

Price match promise: "If you find the exact same part or accessory elsewhere for cheaper, we’ll not only match it, we’ll beat it!" -

Buy your appliance spare part



×
×
  • Create New...